Making the Interakt products compatible with PHP5.4 or more

Any tips and tricks that has to with the interakt extensions that doesn't fit into one of the other categories
avpman
Posts: 14
Joined: 2013-02-20 20:21

Re: Making the Interakt products compatible with PHP5.4 or more

Postby avpman » 2017-04-29 19:26

macJack wrote:ADDT now also working like a charm with php7 an mysqli, with a small conversion script. Costed a few dollars, but was worth it.


Hi,
Would you be willing to share the script for a share of the cost? I need the mysql_pconnect's converted to mysqli for PHP5.6
Thanks!
macJack
Posts: 12
Joined: 2012-06-14 12:26

Re: Making the Interakt products compatible with PHP5.4 or more

Postby macJack » 2017-07-06 11:54

Just download the 5.3 update. It will work with 5.6 as well
avpman
Posts: 14
Joined: 2013-02-20 20:21

Re: Making the Interakt products compatible with PHP5.4 or more

Postby avpman » 2017-07-06 15:12

Yes, it does. But if you turn on PHP error notifications on your server you will see that the program modules complain incessantly about soon to be deprecated MySql functions in favor of MySQLi. MySsql_*() is now deprecated and will be removed soon. You shouldn't use it for new code.

Examples of the changes need can be found here: http://uk1.php.net/manual/en/mysqli.quickstart.dual-interface.php
User avatar
Fred
Site Admin
Posts: 484
Joined: 2010-02-15 12:10
Location: Armagh, Northern Ireland
Contact:

Re: Making the Interakt products compatible with PHP5.4 or more

Postby Fred » 2017-09-27 05:04

Hi avpaman we are currently working on getting the includes folders for interakt updated to be php 7 compatible as well.
Please hang in there with us while we get it sorted.
Fred
eXel content Management Systems (XMS Systems)

Please click the "Accept the Answer" icon if you are happy with the response.
avpman
Posts: 14
Joined: 2013-02-20 20:21

Re: Making the Interakt products compatible with PHP5.4 or more

Postby avpman » 2017-09-27 13:49

This is great news!
Thank you immensely.
energylevels2012
Posts: 58
Joined: 2012-07-22 16:41

Re: Making the Interakt products compatible with PHP5.4 or more

Postby energylevels2012 » 2017-10-19 13:42

Give me a shout please Fred when you've done the PHP 7 changes ...
User avatar
Fred
Site Admin
Posts: 484
Joined: 2010-02-15 12:10
Location: Armagh, Northern Ireland
Contact:

Re: Making the Interakt products compatible with PHP5.4 or more

Postby Fred » 2017-10-20 02:54

Will do as soon as we are happy with the results.
Fred
eXel content Management Systems (XMS Systems)

Please click the "Accept the Answer" icon if you are happy with the response.
titopuentes
Posts: 2
Joined: 2013-04-19 09:48

Re: Making the Interakt products compatible with PHP5.4 or more

Postby titopuentes » 2018-04-10 18:43

Hello friends,

I just changed my server to a new one and I have a big problem. Lowest PHP version on my server is 5.6.31 and now my web-app is giving my a lot of problems...

I just downloaded last fixes to php 5.5 but file KT_FakeRecordset.cass.php gives error at line 115. It said only 1 parameter given, so I modified to:

Code: Select all

$insert_values .= "'" . mysqli_real_escape_string($this->connection, $value) . "', ";

And now I have this error:
mysqli_real_escape_string() expects parameter 1 to be mysqli, object given

Anyone knows where is the problem?
RM2017
Posts: 5
Joined: 2017-03-01 14:58

Re: Making the Interakt products compatible with PHP5.4 or more

Postby RM2017 » 2018-04-16 16:40

I would be more than willing to help share the cost of this or any other update like this. here's my email address send me a message

[email protected]
User avatar
Fred
Site Admin
Posts: 484
Joined: 2010-02-15 12:10
Location: Armagh, Northern Ireland
Contact:

Re: Making the Interakt products compatible with PHP5.4 or more

Postby Fred » 2018-04-20 08:35

titopuentes wrote:Hello friends,

I just changed my server to a new one and I have a big problem. Lowest PHP version on my server is 5.6.31 and now my web-app is giving my a lot of problems...


Not sure what your problem is but I am running php 5.6.35 on my servers and everything is working just fine.
I am using the patches as on the website.

Ran into a spot of trouble with the php 7 fixes but will hopefully be working on that soon.
Fred
eXel content Management Systems (XMS Systems)

Please click the "Accept the Answer" icon if you are happy with the response.

Return to “MX Kollection - General Info”

Who is online

Users browsing this forum: No registered users and 0 guests