Making the Interakt products compatible with PHP5.4 or more

Any tips and tricks that has to with the interakt extensions that doesn't fit into one of the other categories
litonbd
Posts: 2
Joined: 2015-01-28 09:13

Re: Making the Interakt products compatible with PHP5.4 or more

Postby litonbd » 2018-04-28 00:46

Fred wrote:Hi avpaman we are currently working on getting the includes folders for interakt updated to be php 7 compatible as well.
Please hang in there with us while we get it sorted.


Hello Fred

How is the position of the script conversion? Let us know the update, Thanks.
avpman
Posts: 14
Joined: 2013-02-20 20:21

Re: Making the Interakt products compatible with PHP5.4 or more

Postby avpman » 2018-06-10 16:46

Fred wrote:Hi avpaman we are currently working on getting the includes folders for interakt updated to be php 7 compatible as well.
Please hang in there with us while we get it sorted.


Hi Fred. Just thought I'd check in and see how the updates are coming along. Thanks!
User avatar
Fred
Site Admin
Posts: 484
Joined: 2010-02-15 12:10
Location: Armagh, Northern Ireland
Contact:

Re: Making the Interakt products compatible with PHP5.4 or more

Postby Fred » 2018-06-10 18:57

Making good progress.
Fred
eXel content Management Systems (XMS Systems)

Please click the "Accept the Answer" icon if you are happy with the response.
avpman
Posts: 14
Joined: 2013-02-20 20:21

Re: Making the Interakt products compatible with PHP5.4 or more

Postby avpman » 2018-06-10 19:38

Fred wrote:Making good progress.


Any estimate of time, weeks, months, end of year?
Thanks!
ragni
Posts: 2
Joined: 2018-03-21 01:29

Re: Making the Interakt products compatible with PHP5.4 or more

Postby ragni » 2018-08-20 00:24

Just wanted to know if you have made any progress or if you need anything to complete this.
[email protected]
Posts: 8
Joined: 2012-09-25 12:32

Re: Making the Interakt products compatible with PHP5.4 or more

Postby [email protected] » 2018-09-18 18:00

Thank you very much for your answers.
The problem is solved
energylevels
Posts: 3
Joined: 2012-07-22 15:40

Re: Making the Interakt products compatible with PHP5.4 or more

Postby energylevels » 2018-11-19 07:14

I think for you guys looking for a PHP 7 compatible version of Kolleciton the best option is to use PHAKT which uses the PHP ADODB database abstraction layer so it works with MySQLi and many other database types too .... and yes it works with Kollection off the bat.

I don't think it would be easy upgrade existing sites you've created that use old MySQL connection but you would be able to create new websites that are compatible with PHP 7.

I have been working on updating the PHAKT and Kollection framework and have so far got a working application running on PHP 7.2 with nextensio list, form, login etc. I have:

Updated PHP ADODB files to the latest version that works with PHP 7.2.
Updated the old interakt files connected to the ADODB PHP layer
Updated all the PEAR libraries in the kollection includes folder to the latest versions
Updated other Kollection includes files fixing deprecated warnings, notices and errors for compatibility with PHP 7.2 and future versions.

I alsO had to update the Dreamweaver ADODB connection file in the _mmServerScripts folder too as it wasn't working in PHP 7.

It was only a first run but managed to get everything working to fashion without any extensive testing.

More extensive testing and updating/repacking new extensions requires a lot of work though. If anyone is interested in chipping and paying for the time it will take to do this let me know and I may consider doing....
[email protected]
Posts: 8
Joined: 2012-09-25 12:32

Re: Making the Interakt products compatible with PHP5.4 or more

Postby [email protected] » 2018-12-04 23:18

energylevels wrote:I think for you guys looking for a PHP 7 compatible version of Kolleciton the best option is to use PHAKT which uses the PHP ADODB database abstraction layer so it works with MySQLi and many other database types too .... and yes it works with Kollection off the bat.

I don't think it would be easy upgrade existing sites you've created that use old MySQL connection but you would be able to create new websites that are compatible with PHP 7.

I have been working on updating the PHAKT and Kollection framework and have so far got a working application running on PHP 7.2 with nextensio list, form, login etc. I have:

Updated PHP ADODB files to the latest version that works with PHP 7.2.
Updated the old interakt files connected to the ADODB PHP layer
Updated all the PEAR libraries in the kollection includes folder to the latest versions
Updated other Kollection includes files fixing deprecated warnings, notices and errors for compatibility with PHP 7.2 and future versions.

I alsO had to update the Dreamweaver ADODB connection file in the _mmServerScripts folder too as it wasn't working in PHP 7.

It was only a first run but managed to get everything working to fashion without any extensive testing.

More extensive testing and updating/repacking new extensions requires a lot of work though. If anyone is interested in chipping and paying for the time it will take to do this let me know and I may consider doing....


Thank you forever for these efforts.
And courage!

Return to “MX Kollection - General Info”

Who is online

Users browsing this forum: No registered users and 4 guests